
 
 

General Description 

In Chemked, the thermodynamic data is collected in databases and stored in 
Microsoft Access file type; the files should have the ‘.mdb’ extension. For each 
species, the data are presented as seven polynomial coefficients for each of two 
temperature ranges. The polynomials are used for calculating the specific 
thermodynamic functions (the heat capacity at constant pressure Cp, the 
enthalpy H and the entropy S,). More information on this subject can be found in 
the following topics. 
 
In the program the data is displayed in tables and handled via the user interface. 
You can edit the data, sort and select species with particular properties. 
Chemked provides numerical and graphical information on the thermodynamic 
functions. Data and charts can be printed or exported to the clipboard or as a file. 
The data is checked and if there are problems will display error messages. 
 
You can create and save several thermodynamic (THERMO) databases, but 
Chemked can be connected with only one at a time. After connection with a 
thermodynamic database you can process several reaction databases 
simultaneously.  
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Reaction Database Reaction Database 
 

 
  Relationship between thermodynamic database and reaction databases   
 
When editing a reaction database the information from the connected 
thermodynamic database is used for checking the reactions. Due to the way the 
program connects to the thermodynamic database the user needs to follow 
certain rules: 
  
1) To connect the program to another thermodynamic database you should first 
close the connected thermodynamic database and all reaction databases before 
proceeding. 
2) To edit the connected thermodynamic database you should first close all 
reaction databases.  



 
Note. If you do not need to work with the connected thermodynamic database, 
you may close it. Chemked remains connected to the closed database and the 
thermodynamic information will be available in Chemked subroutines. 

Text Format of Thermodynamic Data  

The specific thermodynamic properties of a species (the heat capacity at 
constant pressure Cp, the enthalpy H and the entropy S) are presented as a set 
of polynomial coefficients. 
 

4
5

3
4

2
321/ TaTaTaTaaRCp ++++=  

TaTaTaTaTaaRTH /5/4/3/2// 6
4

5
3

4
2

321 +++++=   

7
4

5
3

4
2

321 4/3/2/ln/ aTaTaTaTaTaRS +++++=  
 
where R is the universal gas constant, T is temperature in K, a1-a7 are polynomial 
coefficients. A set of the seven coefficients is valid for a limited temperature 
interval. To expand the limits, two coefficient sets for overlapping intervals are 
used. An example of the thermodynamic data in the CHEMKIN-II text format is 
shown here. 
 
H2O 20387 H 2O 1 0 0G 300.00 5000.00 1000.0 1
2.67214600E+00 3.05629300E-03-8.73026000E-07 1.20099600E-10-6.39161800E-15 2

-2.98992100E+04 6.86281700E+00 3.38684200E+00 3.47498200E-03-6.35469600E-06 3
6.96858100E-09-2.50658800E-12-3.02081100E+04 2.59023300E+00 0.00000000E+00 4

The first line contains species name, reference, elemental composition, phase, 
temperature ranges for which coefficients apply. In the following lines the 
polynomial coefficients are placed.  
 
Important.  Thermodynamic data is format sensitive and provides errors if not 
formatted exactly. 
 
The user can, but not must, specify the polynomial coefficients. A polynomial is 
identified as unspecified if the ALL coefficients are zero; otherwise the polynomial  
is specified. The thermodynamic functions cannot be calculated for species with 
unspecified polynomials.  

O3 O 3 0 0 0G 200.00 3000.00 1000.0 1
0.00000000E+00 0.00000000E+00 0.00000000E+00 0.00000000E+00 0.00000000E+00 2
0.00000000E+00 0.00000000E+00 0.00000000E+00 0.00000000E+00 0.00000000E+00 3
0.00000000E+00 0.00000000E+00 0.00000000E+00 0.00000000E+00 0.00000000E+00 4

 
 



 
Remark -------------------------------------------------------------- 
If your reaction mechanism contains species whose thermodynamic functions are 
unknown, you should include these species in database as species with 
unspecified polynomials. Elemental compositions of these species are used to 
check balance of elements in reactions. 
---------------------------------------------------------------------------- 

Species Name  
Species name is a sequence of any characters; a name may have maximum 
length of 16 characters. The name must be unique. The species names are 
case-sensitive. The names C2H(s) and C2H(S), SiO2 and SIO2 are different. 
 
Some symbols are forbidden for use in the species names. The forbidden 
symbols inhibit the interpretation of reaction formulas. These symbols are  
 
 =, < , >, $ and blank space.  
 
The sign '+' is used for the positive ion designation. A species name may end 
with any number of '+'s without parentheses. The use of embedded '+'s in the 
names is forbidden.   
 
Example. 
 Correct species names are Ar, C6H8, H, Methane, 1,2-C4H6, C2H(s), C+. 
Incorrect species names are C2H<S>, HN=C=NH.  

Molecular Formula 

Molecular formula states the number and type of chemical elements present in a 
molecule. This information is placed on the first line after the reference. The 
maximum number of elements in a chemical compound should not exceed 4. 
Chemked uses molecular formulas, not names, for checking balance of chemical 
elements in reactions.  
 
Example.  
If you specify species with different names H2O and Water that have the identical 
molecular formulas H1O2 then the following reactions will be equivalent. 
 
H2O + M = OH + H + M 1.91E+23 -1.83 118500
Water + M = OH + H + M 1.91E+23 -1.83 118500



Creating a New Thermodynamic Database 

1.  Close all child windows including currently connected thermodynamic 
database. 
2.  Choose File > THERMO Database > New. The File dialog appears. 
3.  In the dialog, specify a database file path; click the Open button. 
 
The program connects to the new database and the THERMO window with an 
empty thermodynamic table opens. The path of this database is saved; the next 
time Chemked is opened this database will be opened automatically as the 
default. 
 
Note.  We recommend you enter data into the new database immediately. If the 
database is empty you cannot open any reaction databases! 

Connecting the Program to a Thermodynamic 
Database 

Chemked should be always connected to a thermodynamic database. You can 
change it by choosing another database from existing ones. To do this the 
following steps should be carried out. 
 
1.  Close all child windows including currently connected thermodynamic 
database. 
2.  Choose File > THERMO Database > Connect. The File dialog appears. 
3.  In the dialog, select the database file path; click the Open button. 
 
The program connects to this database and the THERMO window opens. The 
path of this database is saved; the next time Chemked is opened this database 
will be opened automatically as the default. 
 
Note.  Make sure that the database file is not read-only. 

Valid and Invalid Properties of Species 

A species has Invalid property when its name contains forbidden symbols ( =, < , 
>, $ or blank space) or is not unique (the name is a duplicate). Otherwise the 
species has the Valid property. In the THERMO table, the invalid species are 



highlighted. Information from the thermodynamic database is used for checking 
reactions; the invalid species will be ignored. 
 

Entering Chemical Elements 

1.  Close all reaction databases and activate the THERMO window. 
2.  Choose Edit > Chemical Elements 
     or on the toolbar, click the Chemical Elements button.  
A window with the chemical element table appears.  
3.  In fields of the table, enter or remove the chemical element names and atomic 
weights; click OK.  
The changes are written to the database and the element window closes.  
 

    
 
  Chemical element table 
 
Important. If an element is removed from the element table, all species 
containing this element will be also removed from the THERMO table. 
   
Remark -------------------------------------------------------------- 
The maximum number of chemical elements is 10.  The element name should 
consist of 1 or 2 letters. 
 
Each thermodynamic database has an own element table. 
---------------------------------------------------------------------------- 
 
 
 



Entering Species 

Paste Data 

This method can be used when data is available in an electronic form, for 
example, as a text file. You should copy the data to the clipboard and then carry 
out the following steps. 
1.  In the THERMO table select a row. 
2.  Choose Edit > Paste  
     or on the toolbar, click the Paste button. 
The data will be pasted in the THERMO table below the selected row.  
 
 
Remark ----------------------------------------------------------- 
If you need to enter a large volume of data (more than a few hundred species), 
we recommend you to enter the data in parts. 
 
In the CHEMKIN standard representation the data is written as a sequence of 
lines where the first and last lines contain the key words THERMO and END 
respectively To use this data you should copy all the text between, not including, 
the key words. An error will occur if the data contains key words, such as 
SPECIES, THERMO, END, or another auxiliary information. 
----------------------------------------------------------------------- 

Paste Special 
Sometimes values of the common temperature of temperature intervals are 
omitted in the descriptions, as shown here. 
 
iC4H7 P11/94C 4H 7 0 0G 300.000 3000.000 1
0.74491956E+01 0.22630504E-01-0.88095014E-05 0.14336478E-08-0.73247269E-13 2
0.11196182E+05-0.11947779E+02 0.34512660E+01 0.24686039E-01 0.52359514E-05 3

-0.16130826E-07 0.53881687E-11 0.12783361E+05 0.11080150E+02 4 
 
There are also special cases when the reference is too long and it must be 
placed in the name field as it shown in this example. 
 
oh 7/13/ 0 rucich 1o 1 0 0g 300.000 5000.000 1710.000 01
2.85376040e+00 1.02994334e-03-2.32666477e-07 1.93750704e-11-3.15759847e-16 2
3.69949720e+03 5.78756825e+00 3.41896226e+00 3.19255801e-04-3.08292717e-07 3
3.64407494e-10-1.00195479e-13 3.45264448e+03 2.54433372e+00 4 

 
The following procedure can be used to input these types of data. As previously 
detailed you should first copy the data to the clipboard. The descriptions of the 
species can contain or not contain the common temperature. Then carry out the 
following steps. 



 
1.  In the THERMO table select a row. 
2.  Choose Edit > Paste Special. The Paste Special dialog appears. 
3.  In the frame 'Common temperature of temperature intervals', check 'Insert 
default value', and type the default value in the text box.  
4.  In the frame 'Species name is defined as' chose the option 'Characters from 
the first position to the first blank spac' 
5.  Change the letter case of names of species and chemical elements if it is 
needed. 
6.  Click the Paste button. 
 
The species will be pasted into the THERMO table below the selected row. The 
default value of the common temperature will be inserted in the species where 
these values were absent. 
 

   
 
  Paste Special dialog 

Comments 

Lines with the exclamation mark (!) in the first position are comments; they will be 
written in the Comment field of the THERMO table. The comment for a species 
may have maximum length of 256 characters. An example of the comment is 
shown here: 
 
h2o2 120186h 2o 2 g 0300.00 5000.00 1000.00 1
0.04573167e+02 0.04336136e-01-0.01474689e-04 0.02348904e-08-0.01431654e-12 2

-0.01800696e+06 0.05011370e+01 0.03388754e+02 0.06569226e-01-0.01485013e-05 3
-0.04625806e-07 0.02471515e-10-0.01766315e+06 0.06785363e+02 4
! Review and release date: May 19, 2004
! 4/16/04 version 1a

Remark -------------------------------------------------------------- 
In the following example, the data have the CHEMKIN format and are recognized 
by CHEMKIN. Nevertheless, the error occurs if you will attempt to input the data 



in Chemked. The C5H10 description contains 5 elements N, AR, C, H and O; 
only 4 elements are allowable. 

C5H10 000000N 0AR 0C 5H 10O 0G 300 5000 1000 1
4.62768794E+00 3.99163471E-02-1.76584355E-05 2.94527974E-09 0.00000000E+00 2

-5.90930391E+03 3.39515508E+00-1.36099451E+00 5.87684877E-02-3.93332993E-05 3
1.36933176E-08-1.93663167E-12-4.42142034E+03 3.36502744E+01 4

 
In this case, you receive the message 'Error in temperature intervals'.  
----------------------------------------------------------------------- 

Manual input 
1.  In the THERMO table, select a row. 
2.  Choose Edit > Insert New Row  
     or on the toolbar, click the Insert New Row  button 
     or right click mouse on the selected row and choose Insert New Row from 
the pop-up menu. 
A new row will be created below the selected row. 
3.  Double click the new row; the input window appears. 
4.  Type the data into the text boxes of the input window; click OK. 
 

      
  
  Input window of the THERMO table, the features for entering species name and 
molecular formula 
 
 
 



Editing Data 

1.  Double click the field of the THERMO table with a value you want to change. 
The input window appears. 
2.  In the corresponding text box of the input window, change the value; click OK. 

Creating Charts and Viewing Numeric Data 

You can create charts and view numeric data of the following thermodynamic 
functions: enthalpy, entropy and heat capacity at constant pressure. 

Selecting Functions 

1.  Choose View > Chart and Numeric Data Dialog 
     or on the toolbar, click the Chart and Numeric Data Dialog button. 
The dialog appears.  
2.  In the dialog, select the functions you want to view, and specify the interval 
and step of temperature; click OK. 
 

    
 
  Dialog for selecting thermodynamic functions 
 
 



Plotting Functions 

1.  In the THERMO table, select a species whose functions you want to plot. 
2.  Double click the row header; curves of the chosen functions appear in 
Temporary Chart. 
If this procedure is repeated for different species the existing curves will be 
replaced with new ones. If you want to add curves to existing Temporary Chart, 
hold down the Ctrl key and then double click the corresponding row header. 
 

 

Saving Temporary Chart 
Temporary Chart is deleted when the program closes. To save the chart you 
should carry out the following steps. 
1.  Activate the Temporary Chart window. 
2.  Choose File > Save As. The File dialog appears.  
3.  In the dialog, specify a file path; click the Save button. 
 
Important.  The file name should have the ‘.pg’ extension.  

Viewing Numeric Data 

1.  In the THERMO table select a species whose numeric data you want to view.  
2.  Choose View > Numeric Data of Current Species  
     or right click mouse on the selected species and choose Numeric Data of 
Current Species from pop-up menu. 
Numeric data of the thermodynamic functions will appear in a text window. You 
can print this or save it to a file. 
 
 


